Increased latency resulting in slow performance

Incident Report for Layer Systems

Resolved

This incident has been resolved.
Posted Oct 06, 2025 - 10:43 BST

Identified

We're currently investigating reports of latency affecting some requests. We'll update this page when we have further information.
Posted Oct 03, 2025 - 09:28 BST
This incident affected: Layer App.