Issue with File Access in Production Environment
Incident Report for Layer Systems
Resolved
The timeout issue affecting file access in our production environment has been fully resolved. Our investigation revealed that this problem stemmed from specific changes made during our recent release activities. The technical team has worked to address this issue, ensuring that full access to files is now restored.

We recognise that this incident may have caused delays and access failures, impacting users who rely on our production environment for their work. We regret any inconvenience or disruption this may have caused and extend our sincere apologies.

Initial Root Cause Analysis (RCA)

Identified Cause: The issue was traced to particular modifications in our latest release.
Corrective Actions: Our team promptly implemented corrective measures to address the issue, focusing on restoring system stability.
Future Prevention: We will conduct a review of our release procedures. This review aims to identify and implement improvements that will prevent similar incidents from occurring in the future.

We appreciate your patience and understanding and are dedicated to maintaining the reliability and performance of our services.
Posted Dec 12, 2023 - 10:17 GMT
Identified
We are currently experiencing a timeout issue when accessing files in our production environment. This problem is affecting the ability to retrieve and interact with files, potentially impacting various services and user experiences.
Posted Dec 12, 2023 - 09:34 GMT
This incident affected: Layer App.