Elevated Errors and Slow Response Times on The Layer

Incident Report for Layer Systems

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 09:35 GMT

Monitoring

🕒 Timeframe: 8:15 AM – 8:40 AM GMT
⚠️ Impact: Users may have experienced degraded performance, including slower page loads and increased error rates.

The issue was traced to an underlying infrastructure issue on one of our production servers. We have taken immediate steps to stabilise the environment and are actively investigating root causes to prevent recurrence.

We understand how frustrating this is and deeply appreciate your patience. If you're still experiencing issues, please refresh your session or contact support.
Posted Mar 26, 2025 - 08:45 GMT
This incident affected: Services (Mail Triage) and Layer App, Layer API, Layer Exchange & Office 365 Connector, Data Manager.