Mail Triage delays
Incident Report for Layer Systems
Resolved
This incident has been resolved.
Posted Jul 29, 2022 - 21:28 BST
Identified
We are currently experiencing latency with Mail Triage service in all regions, and are actively investigating.
Posted Jul 29, 2022 - 21:11 BST
This incident affected: Layer Exchange & Office 365 Connector.