System wide issue with notifications
Incident Report for Layer Systems
Resolved
Our technical team have resolved this issue.

Please contact support on 03333 222 000 for any queries relating to this incident.
Posted over 1 year ago. Apr 13, 2018 - 12:24 BST
Investigating
Our technical team is currently investigating a system wide issue with email notifications. Customers may experience delayed or undelivered messages. We will append this incident as soon as updates become available.
Posted over 1 year ago. Apr 13, 2018 - 10:19 BST