Connectivity issues with Microsoft Exchange and Office 365 services
Incident Report for Layer Systems
Resolved
This incident has been resolved.
Posted Jun 08, 2021 - 15:36 BST
Monitoring
The upstream provider has fully restored services as of 11:52 BST this morning. We will continue to monitor this throughout the day.
Posted Jun 08, 2021 - 11:59 BST
Update
Engineers have identified the root cause as a major outage with an upstream cloud computing provider. Measures have been put in place to mitigate this, and most services are starting to return to normal.
Posted Jun 08, 2021 - 11:46 BST
Identified
We have been experiencing issues with Exchange and Office 365 services since 08:48 this morning. Engineers are investigating this issue, and we will update this ticket as soon as we have further information.
Posted Jun 08, 2021 - 10:23 BST
This incident affected: Layer Exchange & Office 365 Connector.